[#8851] - Error in reading fields list in the dataset dialog

Category:
Bug report
Priority:
Normal
Status:
Feedback Requested
Project: Severity:
Minor
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

Hello,

we are using a Custom JasperReports Datasource Provider as Data Adapter.

If the report contains an error, i.e. in the body there’s the reference to a not existent field, the Read Fields button in the dataset and query dialog doesn’t work, and we get the following exception

java.lang.ClassCastException: net.sf.jasperreports.engine.design.JRValidationFault cannot be cast to net.sf.jasperreports.engine.design.JRValidationFault

In attachment you have a doc with more info and a sample workspace where the problem has been reproduced.

Please let me know if you need more info.

Thank you
Giovanni

v6.3
giovstef's picture
Joined: Sep 23 2016 - 5:59am
Last seen: 1 week 1 day ago

6 Comments:

#1
  • Status:New» Feedback Requested
  • Assigned:» chicuslavic

Could you record a screencast, add a report with an error in body, put some valid values for REPORT_DSNAME . I have difficulties reproducing your problem.

#2
  • Resolution:Open» Unable to Reproduce

In your case you use JRDataSourceProvider , if you look inside there is a parameter JasperReport, so, we have to pass current report into there, compile it. If you have problems inside your report, first fix them.

#3

Indeed the Ireport versions of the IDE didn't have this problem, and we've been using JRDataSourceProvider since then. It's really difficult sometimes to fix the report before reloading the datasource. Sometimes we produce a new report by copying it from another one, we change the datasource and proceed to modify the report. That's when the issue shows up.
Do you still need me to record a screencast of the problem?

#4

You repeated what you said before. Please record a screencast using zip file you attached, so I can reproduce your case.

#5

I know I repeated what I said before. By reading your comment I thought you didn't read my document at all. Anyway, I'll open the sample I attached and I'll hit the "read fields" button. In the meantime I'll register the procedure.

#6

Hello,
just added the video to reproduce the problem

Feedback
randomness